Connect with us
The-Legend-of-Zelda-Skyward-Sword

News

Wii U system update required to play Wii software

You will be required to download the Wii U system update available at launch in order to play Wii games, IGN report.

As revealed earlier in the week, the Wii U system update will also add online services including Miiverse, Nintendo TVii and Wii U Chat.

It now appears that backwards compatibility will also be added through this. Having inserted a Wii disc to their review unit to play, the console notified them that a system update would be required before they may use it.

Click to comment

Leave a Reply

Advertisement

Follow Us

Advertisement
Manage Cookie Settings